Help with SODAQ SARA SFF needed

Hey folks,

I'm currently trying to get RIOT to fly on the SODAQ SARA SFF board. Unfortunately I'm struggling a little bit with the startup sequence of the U-Blox module. According to the documentation here: and the Arduino samples provided by SODAQ I assumed that I would need to call SARA_ENABLE_ON and SARA_TX_ENABLE_ON, followed by toggling SARA_R4XX_PWR_ON_PIN, but I still fail to read the firmware via an AT command. Anyone with experience with the SODAQ boards and the SARA U-Blox module?

Cheers Oleg

Hi Oleg,

I started a driver for the Ublox device on this branch [1]. It is limited but it is working on the SODAQ SARA AFF board. I don't know if the pins change on the SFF version of the board, but you can give it a try. Hope that helps.

Cheers, Leandro.


Hey Leandro,

that looks very helpful indeed - thanks a lot!

Unfortunately, I still get no response from the modem - but the Arduino example isn't working either, so maybe it's a problem with the hardware.

Cheers Oleg