VS Code doesn't recognize types from other board configuration than native

Hello everyone,

while working with RIOT I noticed that VS Code hast trouble recognizing the correct header files that are board specific and instead assumes I am using the native configuration. I tried to generate the compile_commands.json and added the RIOT extension, but the required types are still missing in the IDE, while they seem to be there once I flashed the app on the board. The Board I am working with is the micro:bit v2 and I am including the cpu_conf.h. Thanks in advance for your help!

When generating compile-commands, did you also specify the board? So

make BOARD=microbit-v2 compile-commands

Yes, I also specified the board. I dont know if this is relevant, but I tried to generate the file in the project folder itself and in the RIOT root directory. For me there was no difference in the generated file, so I kept the generated file from the project folder. Is it important from where I generate the compile-commands?

Also note that the RIOT extension for VScode is quite outdated. (And not maintained anymore IIRC). You may experience issues with it.