Thingy52: Real time terminal output

Dear All,

I’m not getting through to the shell when running release-2019.07/examples/default on the Thingy:52.

I’m using a JLink-OB on another DK. The following devices show up on Linux: /dev/ttyACM0 /dev/ttyACM1 /dev/ttyACM2

I’ve tried them all with no success.

Programming works fine, but the RTT terminal doesn’t:

Downloading file [release-2019.07/examples/default/bin/thingy52/default.bin]… Comparing flash [100%] Done. Erasing flash [100%] Done. Programming flash [100%] Done. Verifying flash [100%] Done. J-Link: Flash download: Bank 0 @ 0x00000000: 1 range affected (16384 bytes) J-Link: Flash download: Total time needed: 0.327s (Prepare: 0.032s, Compare: 0.004s, Erase: 0.000s, Program: 0.280s, Verify: 0.002s, Restore: 0.007s) O.K.

release-2019.07/dist/tools/jlink/ term_rtt

Starting RTT terminal

Twisted not available, please install it if you want to use pyterm’s JSON capabilities 2019-08-22 22:03:24,215 - WARNING # Host name for TCP connection is missing, defaulting to “localhost” 2019-08-22 22:03:24,216 - INFO # Connect to localhost:19021 Welcome to pyterm! Type ‘/exit’ to exit. 2019-08-22 22:03:25,220 - INFO # SEGGER J-Link V6.48a - Real time terminal output 2019-08-22 22:03:25,221 - INFO # J-Link OB-K22-NordicSemi compiled Feb 14 2019 14:03:18 V1.0, SN=960077373 2019-08-22 22:03:25,221 - INFO # Process: JLinkExe

Any ideas?



Hi Rik,

it has been a while since I last used that board. I have one here, so I will give this a test sometime today. I’ll let you know what I can find out.

Cheers, Hauke

Much appreciated!

Dear All,

Anybody working with a board using RTT terminal? Any direction would be appreciated to get this Thingy:52 talking.

Also tried minicom to perhaps eliminate an issue related to pyterm, but same result.

Cheers, Rik