reboot signature


I am writing because this issue needs resolution:

The problem is that reboot is a common UNIX function with the signature:

    int reboot(int howto)

The new reboot function in RIOT has the signature

    void reboot(void)

I'd like to change our signature for conformity with the existing definition. This would not only help native resolve the conflict but also streamline RIOTs interoperability.

Please discuss.

Cheers, Ludwig

reboot man page: