my PR #1631 changes all msg_* function and structure names to blip_*.
This is a prerequisite to a new messaging API that will be a lot more flexible.
As I'd like to keep the old functions for compatibility and functional reasons, I'm just renaming them for now.
The new API will allow messages bigger than "type"+"content", but will also be content agnostic (no type field).
The old (now blip_*) api will stay the same. I'm thinking to also use them for the riot equivalent of "signals", which will be short messages with defined content, like "exit the thread if you receive this".
Do you have any suggestions for a different name than "blip"?