Problems when building for ESP32

Dear ready to help IOTers,

when trying to build an application for an ESP32 board I run into the following errors:

/data/riotbuild/riotbase/build/pkg/esp32_sdk/components/newlib/syscalls.c:99:9: warning: unknown option after '#pragma GCC diagnostic' kind [-Wpragmas]
 #pragma GCC diagnostic ignored "-Wattribute-alias"
cc1: warning: unrecognized command line option '-Wno-frame-address'
/opt/esp/xtensa-esp32-elf/bin/../lib/gcc/xtensa-esp32-elf/5.2.0/../../../../xtensa-esp32-elf/bin/ld: cannot find crt1-sim.o: No such file or directory
/opt/esp/xtensa-esp32-elf/bin/../lib/gcc/xtensa-esp32-elf/5.2.0/../../../../xtensa-esp32-elf/bin/ld: cannot find _vectors.o: No such file or directory
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:316: /data/riotbuild/riotbase/examples/gnrc_networking/bin/esp32-ethernet-kit-v1_0/esp_bootloader/bootloader.elf] Error 1
make[2]: *** [/data/riotbuild/riotbase/Makefile.base:31: ALL--/data/riotbuild/riotbase/cpu/esp32/bootloader] Error 2
make[1]: *** [/data/riotbuild/riotbase/Makefile.base:31: ALL--/data/riotbuild/riotbase/cpu/esp32] Error 2
make: *** [/data/riotbuild/riotbase/Makefile.include:738: application_gnrc_networking.module] Error 2
make: *** [/home/oleg/git/RIOT/makefiles/] Error 2

I get the same error when building with BUILD_IN_DOCKER=1 or without. However, thanks to @kYc0o I learnt that setting DOCKER_IMAGE to schorcht/riotbuild_esp32_espressif_gcc_8.4.0 will actually work. Now I wonder if this is a particular problem on some distributions or why this setup is not the default configuration.

Cheers Oleg