Native 'board' on OS X Mavericks


I was trying to compile RIOT on OS X using the native “board” and ran into multiple issues:

1) ‘make’ does not work when using the ‘-j’ option to compile with multiple threads. However, using only one thread worked fine.

2) The reboot function seems to conflict with the signature of reboot in '/usr/include/unistd.h’. Here is the compiler error:

In file included from native-uart0.c:36: In file included from /Users/noir/RIOT-OS/RIOT/core/include/thread.h:26: /Users/noir/RIOT-OS/RIOT/core/include/kernel.h:102:15: error: conflicting types for 'reboot' NORETURN void reboot(void);               ^ /usr/include/unistd.h:680:6: note: previous declaration is here int reboot(int);          ^ 1 error generated.

Adjusting the signature to match 'int reboot(int)’ worked fine, at least on OSX.

3) When compiling ‘test_getpid’ from the projects repo, the compilation failed with the following error:

gcc /Users/noir/RIOT-OS/projects/test_getpid/bin/native/startup.o -o /Users/noir/RIOT-OS/projects/test_getpid/bin/native/test_getpid.elf /Users/noir/RIOT-OS/projects/test_getpid/bin/native/cpu.a /Users/noir/RIOT-OS/projects/test_getpid/bin/native/core.a /Users/noir/RIOT-OS/projects/test_getpid/bin/native/sys.a /Users/noir/RIOT-OS/projects/test_getpid/bin/native/native_base.a /Users/noir/RIOT-OS/projects/test_getpid/bin/native/test_getpid.a -m32 -gc -ldl -Wl,-no_pie clang: warning: argument unused during compilation: '-gc' Undefined symbols for architecture i386:   "__native_LED_GREEN_OFF", referenced from:       _board_init in native_base.a(board_init.o)   "__native_LED_RED_ON", referenced from:       _board_init in native_base.a(board_init.o) ld: symbol(s) not found for architecture i386 clang: error: linker command failed with exit code 1 (use -v to see invocation) make: *** [all] Error 1

In a few cases everything went fine and the resulting program could be executed without errors.

Are these problems known? (I searched the Github issues without success.)

Greeting, Raphael Hiesgen

No, i never ran into build errors in osx. Could you please open two issues (reboot, build)?

Thank you, Ludwig

Oh, and another issue for -j while you're at it.. I guess that might be an issue for all platforms.

Cheers, Ludwig