microcoap app


I’m trying to build the microcoap app on Native.

Here is what I get:

workspace/applications-master/microcoap$ make … gcc: error: workspace/applications-master/microcoap/bin/native/microcoap.a: Aucun fichier ou dossier de ce type make: *** [all] Erreur 1

RIOT folder is in workspace as well.

If I change the name “microcoap-example” by “microcoap”, I get:

workspace/applications-master/microcoap$ make … workspace/applications-master/microcoap/bin/native/microcoap.a(main.o): dans la fonction « _microcoap_server_thread »: main.c:(.text+0x30a): référence indéfinie vers « coap_dump » main.c:(.text+0x336): référence indéfinie vers « coap_parse » main.c:(.text+0x384): référence indéfinie vers « coap_dumpPacket » main.c:(.text+0x3a4): référence indéfinie vers « coap_handle_req » main.c:(.text+0x3c4): référence indéfinie vers « coap_build » main.c:(.text+0x418): référence indéfinie vers « coap_dump » main.c:(.text+0x43e): référence indéfinie vers « coap_dumpPacket » collect2: error: ld returned 1 exit status make: *** [all] Erreur 1

Btw, coap pkg is built without errors.

Martin, did I do something wrong?


Hi, I don’t know how much expertise Martin has on the microcoap application, but I tried to compile it against current master and it worked. Did you try a make distclean before make? Sometimes the checkout points for the pkg repositories get a little deprecated.

Cheers, Martine

Sorry, I forgot the “e”, I wanted to mention you. I tried the “make distclean” and it works! I will thinbk about this command next time! Thank you Martine.