Issue with RIOT and OpenMote-B

Hi , I have started working with Tutorial and my openMote-B first of all i Tried the Tutorial-- TASK-01, (TASK-01 is running a SHELL and printing the board name) for the first time the program was transferred successfully but it was done with a error. import serial moduleNotFoundError: No module named 'serial’

anyways i tested with GTKTERM Serial terminal it was working with the OpenMote-B Board after this if i try to transfer any other program or the same program then am getting the following error

ERROR: Timeout waiting for ACK/NACK after 'Synch (0x55 0x55)'

please help me to resolve this issue

Thanks Manikandan

Hello Mani,

I was able to reproduce your issue when leaving a serial connection already open. Please ensure you close your serial connection to the board before attempting to flash or term again. This may explain why the first time you program it works and following times it doesn’t.

So to be clear try the following commands:

cd <directory of Tutorials task 1>

BOARD=openmote-b make flash term

(here you can do what you want such as help or ps)

***PRESS ctrl+c to exit the term

try: BOARD=openmote-b make flash term again to ensure your problem is solved…

On another note you may have the wrong (or no) serial connection installed,

try to: pip uninstall serial then pip install pyserial

And depending on the version of python you could also try pip3

Let me know if that helps,


Thank you for your response Mr.Kevin Actually I also thought the samebthing due to the running shell only it gives the problem .but unfortunately the shell i’m unable to see instead of that only I got that import serial error . so that i have used GTKTERM (serial terminal sortware) in that i’m able to see the running shell and can give the ps help commends also but i can’t able to stop that running shell in the openmote-B.i just want to know that how to stop or how to reset the board.

again thanks for your kind response