ifconfig 9 add a02:8109:b6bf:bb24:0292::1 doesn't work

Let’s say my network interface on my notebook has the following IP: a02:8109:b6bf:bb24:f293:aae5:fd69:3924/64

This means I got a02:8109:b6bf:bb24::/64 for my network. Got this range from my ISP. I want to configure my RPL network to have a02:8109:b6bf:bb24:0292::/80 as the IPv6 range.

So I used the following command: ifconfig 9 add a02:8109:b6bf:bb24:0292::1/80

I also tried the following: ifconfig 9 add a02:8109:b6bf:bb24:0292::1

Both doesn’t respond with a success message. The basic idea: I add this route to my Notebook and the router to be able to route the packages to the correct location. Is this a bug or do I understand something wrong about the IPv6 routing?

Hi Philipp,

I’m not one 100% sure about the setup.

  • Which boards are you using for RIOT or are you using native?
  • How is the RIOT instance connected to your notebook? Via ethos, CDC-ECM, Ethernet, …?
  • Did you configure the default route on your RPL root back to your laptop?

Best regards, Martine

Hi Martine,

I use the nrf52dk. 6LoWPAN over BLE (adoption layer). Nimble. It’s a simple tree. root is connected to my Notebook and the other nodes to the root. I already configured RPL with ifconfig 9 add 2001:db8::1. This works fine. But I would like to use another global address and /80 not /64.

  • Did you configure the default route on your RPL root back to your laptop?

Not yet. I give it a try and configure this first. I, more or less, followed this guide. It worked fine with a /64 range.

best regards Philipp

Hi Philipp,

RIOT should have no problems with longer prefixes than 64 bits for global addresses. I noticed however in the past (when configuring my home network without RIOT), that Linux can be a bit difficult with that. Please try configuring the default route first, however.

Best regards, Martine