gcoap, aiocoap, aiocoap-proxy

Hi all,

i have a network setup with a RIOT-node configured as a coap-server and a Linux host as the client. The client uses a python3 script adapted from the aiocoap-package examples. This setup works properly.

As I would like to access the coap server from an http client, I tried to use the aiocoap proxy server. This failed so far, e.g. .

~$ aiocoap-proxy --forward --reverse --server-address [fc00::2:xyz] --server-port 5684

leads to an error message “… socket.gaierror: [Errno -2] Name or service not known”

I tried several variations of the aiocope-proxy command without success.

Does anybody know how to use the aiocoap-proxy command? Could you give me a working example? Thanks in advance.

Best regards, Raimund


while Christian (the main dev of aiocoap) also is part of the RIOT community, I’d suggest you ask at aiocoap about your problem. Seems more related to that than RIOT. This way other aiocoap users in the future.

Feel free to post the solution anyway, to resolve this conversation :-).

Best regards, Martine