Upgrading to 2018.01, LoRa


I’m using RIOT OS to run a LoRa (PHY only) application. I am trying to upgrade to the 2018.01 release, but, after making a few small changes to get the code to compile, LoRa packets are no longer sent - nothing goes out on the air after calling send.

I have a saml21 mcu, an sx1272, and a custom board. Is there anything new in particular that needs to be done to use LoRa with the 2018.01 release?



Could you give a try to the 2018.04 release please ? As I know, several fixes and improvements have been made for SX1272 device.

If it still doesn’t work, could you try to bisect between the 2018.01 release and the previous working branch you used before ?

Best regards


Thanks for your reply. I was able to send messages successfully on the master branch by tweaking the params in sx127x_params.h.

I’ve since run into another issue. I’m now on the the master branch of RIOT, testing with a nucleo-f411 and an mbed sx1276 LoRa shield. When I run the test in pkg_semtech-loramac, I can only receive data confirmations if my data rate is 2 or higher (faster), but I would like to use a data rate of 0 (slower).

Has anyone else encountered this issue?