Syncing fork doesn't upgrade version number

Hello all

I tried to sync my GitHub fork to latest RIOT with “fetch upstream” but when I pulled to local and tested, it still shows version “2021.10-devel”

So I cloned directly upstream and it reports “2022.04-devel”

But cloning fork won’t report latest version even when I checked some files to verify the are upgraded to latest version

Does anybody know what’s wrong?




if I recall correctly, git fetch fetches only branches already tracked. If you throw in an --all argument it will also fetch new branches. You can also single out a branch to fetch and pass it as argument, e.g. of you do not care about all the legacy release branches.

Kind regards, Marian

Thanks for your response

git fetch works OK. If I fetch from upstream, everything is OK

Problem is GitHub fork is not syncing version change and if somebody forks a fork, version upgrades are not reflected

Maybe it’s not a RIOT problem but a GitHub problem.

But it’s affecting RIOT and hence the question


That’s not a bug, but a feature :wink: Github just shows you the state of the git repo you last pushed. There might be a way in the HTML UI to also fetch stuff from the source it was forked (I’m more a command line user myself).

Once you push all branches to your github fork, they should also appear in the web UI.

Well, a fork is a fork, and the forker is responsible to keep it up-to-date. You’ll need to fetch the tags from the original repo, then push them to the fork (git push <remote> --tags) manually.

ah sorry, I was thinking of tags only.

I skipped some detail in the explanation of the problem

  • Official RIOT is 2022.04-develop and fork is 2021.10-devel
  • Fork is synced with GitHub “Fetch and Merge” button. Fork should be in every detail 2022.04-devel
  • Local repo is fetched from fork and git describe shows 2021.10-devel
  • Local repo is fetched from upstream and git describe shows 2022.04-develop

So it has nothing to do with HTML. In fact, I noticed it in RIOT welcome message

The point is it’s a problem, at least for an unsuspecting novice, that a user syncs via web and git is not fully synced and/or RIOT is using a versioning mechanism that GitHub is not syncing

Maybe it deserves a very visible warning

So, you pulled 2021.10-devel, and then you did some work. Maybe you have a new branch name. Then you did a fetch and now you have a 2022.04-devel. It sounds like whatever code you did, you did not rebase.

It also sounds like you tried to do this with github. So, not “HTML”, but with a browser. RIOT can’t put any visible warning in to github. Generally, I would strongly discourage you to use github to manage things until you understand how git actually works.

and then you did some work

No, I didn’t do any mention whatsoever of any work whatsoever

But I did specify version info was taken from “git describe”

You’ll need to fetch the tags from the original repo, then push them to the fork (git push <remote> --tags) manually

That’s the warning I’m talking about suggests it in the “GETTING RIOT” section but it’s not completely clear that GitHub clones tags but won’t fetch them