sixlowapp Ping not working in SAM R21

Hi Lucas,

Thank you. I will apply the patch and update you the progress.

Thanks again. Abdul

Hi Abdul,

The ping issue should be fixed by applying The next problem you might run into with the sixlowapp is that the stacksize settings for the SAM R21 board are currently a little conservative, which causes it to run out of memory when trying to send a UDP packet with the nc command of the sixlowapp. This can be “fixed” by increasing the KERNEL_CONF_STACKSIZE_DEFAULT in RIOT/cpu/samd21/include/cpu-conf.h - I’ve got it to work by increasing it to 1536, but you might have to play around a little.

Cheers, Lucas


Thank you. This worked for me. I increased the KERNEL_CONF_STACKSIZE_DEFAULT to 2K to make things works for my application.

I see that we have problems in making rpl_udp application working in SAM R21 due to the RAM limitation. Is there anyway, we can make this work in the platform?

Thanks Abdul

Yeah you could remove the beacon function. It would properly free 4k of bad

Hi Abdul,

Have you already tried decreasing RPL_MAX_ROUTING_ENTRIES, if that’s possible for your network size?

Cheers, Lotte