RIOT/tests/vtimer_msg/main.c Failure after 1 hour 5 minutes an 32 seconds

Hi Karel,

I'm currently not offering (paid) private consulting for RIOT.

I'll forward your mail to to the public RIOT devel list and the further discussion about your issue should happen there.

Alternatively you can ask for a consultant there, too.

Best Christian


maybe I am not gettting the problem right - but if you read the source:

lines 123 - 126 show

    while (1) {         vtimer_sleep(sleep);         msg_try_send(&m, pid2);     }

that this is regular behavior :slight_smile:

is the way to go to get an first impression - for simple output use helloworld example

Greets Jan

Ok. got it wrong - the SERIAL STOPS! is important. hm sorry - hm what happens if you modify


value? (lower fe.) how many output ? differnt behavoir?

greets Jan

ps sorry for the missunderstanding

I am not certain if Karel joined the mailing list here yet… you might want to include him directly until we know more.

Hello Karel,

Have you managed to solve your vtimer problem? I’ve got a similar problem (different time) on the SAMR21. Look at Jan second answer.


Hi Baptiste, I am sorry, but after the original failure, I tried tweaking a few things like timer intervals, length of text in the print statement etc, but the only difference was in when it failed, e.g. 50minutes, 1hour 10minutes etc. RIOT is/was one of many RTOSes I've been looking at, and the "/RIOT/tests/vtimer_msg" program was the second program I ran, after the hello world program, and frankly I had no time to set up a debugging environment, so I can only guess at the cause. It could be a trap (pointer access to invalid memory etc), a Uart buffer bug, getting locked at empty/full, but not so likely. My final guess is a Semaphore/Mutex lockup bug, because the Uart output is never garbled, is complete, and in my case always ended with   sec=31 min=5 hour=1   sec=32 min=5 hour=1 these lines suspiciously missing from the final lines of output. But who knows...

wish you all luck. Karel

Thank for your answer, I’m going to investigate a bit more. Hopefully the RIOT team will solve those vtimer problem soon.


Hi Baptiste, hi Karel,

the vtimer problems are (infamously) well known at the moment. We are currently putting a timer task-force in place that will focus on re-designing the timer infrastructure. So expect some further information on this soon!

Cheers, Hauke