Flash to board: Nucleo F446RE

Dear RIOT users,

Hello, Recently I downloaded the latest version RIOT-OS 2019-09 and try to execute “default” example at first.

Now it successed to run “native” target and send, receive data by using “txtsnd” command between 2 ports.

Next step, I want to program “default” example into Nucleo-F446RE board. Compiling is no problem, but flashing the board failed as following,

It could be something to do with virtual box (in which case I cannot help) or it could be a number of other things:

  • Check to make sure the nucleo jumpers are correct, near the usb there should be something named ST-LINK, ensure both jumpers are closed
  • Sometimes the nucleos are in a weird power mode and have trouble flashing, to get it out of that state try holding the reset button down and releasing right before the flashing starts
  • If it is something to do with the RIOT flasher or virtualbox you can confirm by simply copying the binary into the nucleo (though you must first create a binary) arm-none-eabi-objcopy -O binary ${RIOTBASE}/examples/default/bin/nucleo-f446re/default.elf <path_to_nucleo_filesystem>.bin

I hope that helps!



If I understand correctly, you are trying to flash the nucleo board from a virtual machine running on a Windows host. In this case, if no NUCLEO-F446 directory is automatically mounted when you plug the board, this means:

  • you have to install the virtualbox extension pack corresponding to your virtualbox version. If I remember correctly, you must stop virtualbox during the setup of the extension.

  • you need to enable USB support in the VM settings and verify virtualbox can share the USB device with the VM.

Let us know if this solves your flashing issue.


Hello. Mr, Abadie,

As you pointed out, The Nucleo-F446RE directory is not automatically mounted. So I needed to add the STM32 ST-Link into the VirtualBox. In detail, STMicroelectronics STM32 ST-Link is added to [Setting]->[USB]->[USB device filter] of VirtualBox.

Now it is possible to flash “default” example to Nucleo-F446RE board. The flashing issue is solved.

Thank you very much for your kind and good advice.

Regards, Dicek Bear.

2019年9月11日(水) 18:17 Alexandre Abadie <alexandre.abadie@inria.fr>:

Hello. Mr Weiss,

At first, I checked the Nucleo-F446RE board jumper settings.The named ST-LINK both jumpers are closed, it was no problem. I checked the VirtuaBox setting as Mr Abadie pointed out. The problem was that the Nucleo-F446RE board was not automatically mounted.

Now the problem is solved. I can flash “default” example to Nucleo-F446RE board.

Thank you very much for your kind and quick support.

Regards, Dicek Bear.

2019年9月12日(木) 17:11 dicek bear <dicek334@gmail.com>: